Skip to content

Hotfixes

The hotfixes repository is desiged as a modularity hotfix repository. This repository provides a set of non-modular packages that can be used to override modular packages provided in CentOS Stream 8. We do this because CBS cannot currently build modular packages, so the only way to ship them within Hyperscale is as non-modular content.

This repository can be enabled by installing the centos-release-hyperscale-hotfixes package:

$ sudo dnf install centos-release-hyperscale-hotfixes

Note that this release package will pull in centos-release-hyperscale, as the hotfixes repo is not meant to be self containerd. In turn, that will pull in epel-release, as EPEL is a prerequisite for Hyperscale. We also recommend enabling PowerTools (which is itself a prerequisite for EPEL) with:

sudo dnf config-manager --set-enabled powertools

Available packages

Browse the release tag on CBS to see what packages are available. Please report any issues with these packages on our package-bugs tracker.

libvirt

We ship an updated backport of libvirt 7.1.0.

LLVM

We used to ship a backport of the LLVM 12 compiler suite. This has since become part of CentOS Stream 8 proper, so we have retired our build.

Back to top